Any Apple boffins about that can assist with an issue with Citrix Receiver?

HaychHaych Frets: 526
I've been using Citrix Receiver for a while and it's a bit buggy but usually does the job.

I was logged into my virtual desktop this morning and my internet bombed out for about ten minutes so I lost the connection.  Ever since whenever I try to log back in I receive an error which states:

"You have not chosen to trust "DigiCert SHA2 Secure Server", the issuer of the server's security certificate. Contact you help desk for assistance."

I can't seem to contact my help desk, so I'm basically stuffed!

The only thing I did between my internet failing and trying to log back in was install Mozilla Firefox, which I had to do to complete an online exam which wasn't compatible with Safari.  I've got rid of Firefox but still no joy with Citrix.

Yes, I have turned it off and back on again.  I have even re-installed Citrix Receiver but still getting no joy.

Can anyone help?

TIA
0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter

Comments

  • guitargeek62guitargeek62 Frets: 1628
    Go into your Safari preferneces and flick through to the security settings - there’s an option in there somewhere or other that allows you to always trust connections to that domain via receiver.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • FunkfingersFunkfingers Frets: 3321
    Haych said:
    Mozilla Firefox
    Firefox strolls in and makes itself the default for a bunch of activities. 

    Go into your Safari preferences and flick through to the security settings.
    The other option is to restore your previous settings from the Time Machine back-up that you made just before installing Firefox. You did make a back-up, didn't you? :)
    "It's no wonder the Pacific Ocean is blue."
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • HaychHaych Frets: 526
    Go into your Safari preferneces and flick through to the security settings - there’s an option in there somewhere or other that allows you to always trust connections to that domain via receiver.
    I've done that and made sure everything is enabled.  However, there's also a greyed-out setting ticked - enable security protection, and below that it states that the plugin is unsafe.  I'm guessing that's what I need to change, but if it's greyed out how do I change it?

    I've also been into my KeyChain and enabled Always Trust on the certificates named in the error but that hasn't made a bit of difference either.  I've changed them back to use system settings since.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
Sign In or Register to comment.