Boss ME-50 problem

What's Hot
clarkefanclarkefan Frets: 467
With some mention of the ME-50 here recently I dug my old one out to have a listen again.

Lots of it works fine but sometimes when I select say phase I get chorus, do it again and I'll get the harmonising thing.

Same thing with the pedal, it will stick on say octave down regardless of setting.

Anybody had this sort of thing happen with a multi? Dust? Borked?


0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter

Comments

  • ICBMICBM Frets: 33302
    Sounds like dust or corrosion in the rotary controls. You could try contact cleaner, but it's the usual fun to get into - the whole board has to come out.

    Try cycling the knobs back and forth a lot and see if it improves first.

    If you don't have contact cleaner, do not try WD-40... it will knacker this type of rotary switch.
    "Take these three items, some WD-40, a vise grip, and a roll of duct tape. Any man worth his salt can fix almost any problem with this stuff alone."
    0reaction image LOL 0reaction image Wow! 1reaction image Wisdom · Share on Facebook Share on Twitter
  • clarkefanclarkefan Frets: 467
    Thanks for the advice ICBM. I'll try twisting the knobs a bit first before having to spend a day dismantling it, but if necessary I've got Servisol and Deoxit, hopefully one of them will do the job :)  Appreciate it!
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
Sign In or Register to comment.