Slight lag recording in Audacity

I've been using Audacity to record myself playing along to an MP3. When I'm playing it all sounds in time, but when I play back my track lags about 150ms behind the original track. I assume there must be some sort of buffering issue going on, but what's the best way to fix it (other than just snipping 150ms out of the start of my track)? Any tips, or is Audacity just not really the right thing to be using?
0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter

Comments

  • steamabacussteamabacus Frets: 926
    edited October 20
    I use Audacity all the time but only as an audio editor, never for multitrack recording.

    But, if you look in Preferences : Devices you will find a section labelled 'latency' with buffer length and latency compensation. My latency compensation seems to be set at -130ms although I've never calibrated it.

    Read here (bottom of page) and follow the link to Latency Test ....
    https://manual.audacityteam.org/man/devices_preferences.html
                                                                                                                                                   My 'Guitar diaries' on BandCamp
                                                                                                                                                            My Soundcloud stream

    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
  • Thanks - will give it a go.
    0reaction image LOL 0reaction image Wow! 0reaction image Wisdom · Share on Facebook Share on Twitter
Sign In or Register to comment.